Posted on Leave a comment

Affordable Windows 10 devices help students learn from anywhere

As schools around the world work to reimagine education, it’s become more important than ever to make technology accessible, safe, and engaging so that educators and students can focus on what matters most: teaching, learning, and connecting with one another. Windows 10 devices and powerful tools like Office 365 for Education and Microsoft Teams work together to help teachers create personalized experiences to support students learning from anywhere.

One example of an institution embracing technology is Frenship Independent School District (ISD). The district, which offers professional certifications and language learning programs, used both Windows 10 devices and Microsoft Teams to manage the shift to remote learning this fall. Before the shift, Frenship ISD had provided student access through a combination of individual devices, computer labs, and “device carts” where devices could be checked in and out to give students access to technology.

Learn how Windows 10 devices can meet your education needs.

Learn more

When Superintendent Dr. Michelle McCord understood that Frenship ISD would be fully remote this fall, she wanted to keep the technology check-out system at the Texas district alive on a larger scale. She worked with the district’s tech department to create a library system for their devices, which were primarily Dell Latitude 3190 computers but also included other Windows 10 devices. Students in the district could select a device that fit their learning needs, use it for the semester and check it back in when they completed their program.

“We fulfilled everyone’s requests. Everybody that needed a device or support for accessing Microsoft systems got it,” said Dr. McCord. The district paired the devices with Microsoft Teams to facilitate collaboration, maintaining a supportive learning environment for students.

With Windows 10 devices and Microsoft Teams connecting students and educators, Frenship ISD is prepared to handle whatever happens in the spring semester and beyond. “We’re ready at any time for a short-term closure, virtual learning, or face-to-face learning,” said Joe Barnett, the district’s Chief Technology Officer. “Blended learning is more of what I think is going to occur. I anticipate students transitioning from one instructional model to the other, and that’s what we really wanted to be prepared for.”

McCord expects the device check-out system will be lasting. “We’re never going to go back to the way it was before,” she explains. “We’re going to keep using this technology so we can be even more productive and stay connected. This will allow us to continue to remain committed to our core beliefs and serve every learner, no matter the circumstance.”

Though we don’t know what this semester will bring for education, we do know that having the right technology is critical as school systems transition to different learning environments. Windows 10 devices and tools like Teams are built to support the success of your school system.

Learn more about affordable Windows 10 devices and find the right fit for your school’s unique technology needs.

Posted on Leave a comment

Chief Data Analytics Officer John Kahan: Thanks to Congress, the FCC can now update America’s broadband maps

Just over a year and a half ago, I wrote about the broadband gap, calling attention to the urgent need for the Federal Communications Commission (FCC) to update their approach to gathering and reporting broadband mapping data. At the time, we knew very clearly that the FCC was vastly undercounting the number of Americans without access to broadband. And because of new research – including our own – we knew the problem to be much larger than previously thought: According to Microsoft’s own data, 157.3 million people in the U.S. do not use the internet at broadband speeds and, according to BroadbandNow, at least 42 million people do not have broadband access at all.

But, today, we know its impacts better than ever. As a result of the Covid-19 crisis, millions of people today aren’t just being left behind, they’re being left out of everyday life. While many can work from home, use telehealth or educate their kids remotely, huge swaths of the country are forced to drive long distances to pick up schoolwork or camp out in public library parking lots to access Wi-Fi. It doesn’t have to be this way.

We often say that we can’t solve a problem we don’t fully understand. Accurate maps are absolutely necessary to help regulators effectively target funding where it is most needed and understand how effectively their funding is being applied to connect those without broadband access.

Fortunately, Congress passed the Broadband DATA Act earlier this year, which would improve the FCC’s mapping data. And we commend Congress for providing broadband funding in the latest Covid-19 stimulus bill signed into law this week, which would begin setting up the new mapping solution. We particularly want to thank Senators Wicker, Thune, Cantwell, Klobuchar and Peters, as well as Representatives Pallone, Loebsack, McEachin, Walden, Latta and Long for their work in including this vital funding in the bill.

But the work doesn’t end there. The FCC must now move forward with standing up the new mapping solution as soon as possible. If they fail to rapidly implement this new accurate mapping solution, rural America will be left in the digital dust. We can’t let that happen. But if they move with the urgency the issue deserves, the FCC can change millions of lives for the better.

Tags: , , ,

Posted on Leave a comment

Home Cooked: Microsoft employees share some of their favorite recipes

Is it breakfast or cookies? Either way, Roxie (@RoxStarBakes on YouTube) has us chomping at the bit for these adorable creations!

Breakfast-shaped sugar cookies

1 c unsalted butter, at room temperature
1 c sifted powdered sugar
1 egg, at room temperature
1 Tbsp vanilla extract
3 c sifted flour
1 tsp baking powder
1/4 tsp salt
Gel food coloring: yellow and red (white is optional)

1. Preheat the oven to 325 degrees Fahrenheit.

2. Using a mixer on medium speed, cream the butter and powdered sugar until they are fluffy and white. Scrape down the sides of the mixing bowl at least twice during this process. Switch the mixer to low speed, and add the egg and the vanilla.

3. In a separate bowl, combine the sifted flour, the baking powder, and the salt.

4. Gradually add the dry ingredients to the wet ingredients one-half at a time, using the mixer on low speed. Mix until everything is combined.

5. Divide the dough into four portions. Leave two portions white (plain), and color the other portions yellow and red. Roll out each portion on a cutting board to about 1/4 inch thickness. Cover with plastic wrap, and refrigerate for 30 minutes. Remove the dough from the refrigerator. Let’s start assembling!

6. To make an egg, use a large circle cookie cutter to cut a circle from the white portion of dough. Use a smaller circle cookie cutter to cut a smaller circle from the yellow portion of dough. Place the small circle on top of the large circle, and you have an egg!

7. To make bacon, place the white portion of dough on top of the red portion. Use a knife to cut the dough into three pieces, and stack them on top of each other with the colors alternating. Slice down through the stack of dough, making bacon strips. Press your fingers on alternating sides of the bacon strips to make the edges squiggly.

8. Continue making cookies, and place them at least 1-inch apart on a baking sheet that is lined with parchment paper. Cover with plastic wrap, and refrigerate for another 30 minutes.

9. Remove the cookies from the refrigerator, and bake them for 8-10 minutes. Let them cool before serving.

Posted on Leave a comment

Using Microsoft 365 Defender to protect against Solorigate

Microsoft security researchers continue to investigate and respond to the sophisticated cyberattack known as Solorigate (also referred to as Sunburst by FireEye) involving a supply chain compromise and the subsequent compromise of cloud assets. While the related investigations and impact assessments are ongoing, Microsoft is providing visibility into the attack chains and related threat intelligence to the defender community as early as possible so organizations can identify and take action to stop this attack, understand the potential scope of its impact, and begin the recovery process from this active threat. We have established a resource center that is constantly updated as more information becomes available at https://aka.ms/solorigate.

This blog is a comprehensive guide for security operations and incident response teams using Microsoft 365 Defender to identify, investigate, and respond to the Solorigate attack if it’s found in your environment. The description of the attack in this blog is based on current analysis and investigations by researchers across Microsoft, our partners, and the intelligence community who are actively collaborating to respond to the attack. This is an active threat that continues to evolve, and the findings included here represent what we know at the time of publishing. We continue to publish and update intelligence, indicators, tactics, techniques, and procedures (TTPs), and related details as we discover them. The report from the Microsoft Security Response Center (MSRC) includes the latest analysis of this threat, known indicators of compromise (IOCs), and initial recommended defenses, and will be updated as new data becomes available.

This blog covers:

Tracking the cross-domain Solorigate attack from endpoint to the cloud

The Solorigate attack is an example of a modern cross-domain compromise. Since these kinds of attacks span multiple domains, having visibility into the entire scope of the attack is key to stopping and preventing its spread.

This attack features a sophisticated technique involving a software supply chain compromise that allowed attackers to introduce malicious code into signed binaries on the SolarWinds Orion Platform, a popular IT management software. The compromised application grants attackers “free” and easy deployment across a wide range of organizations who use and regularly update the application, with little risk of detection because the signed application and binaries are common and are considered trusted. With this initial widespread foothold, the attackers can then pick and choose the specific organizations they want to continue operating within (while others remain an option at any point as long as the backdoor is installed and undetected). Based on our investigations, the next stages of the attack involve on-premises activity with the goal of off-premises access to cloud resources through the following steps:

  1. Using the compromised SolarWinds DLL to activate a backdoor that enables attackers to remotely control and operate on a device
  2. Using the backdoor access to steal credentials, escalate privileges, and move laterally to gain the ability to create valid SAML tokens using any of two methods:
    1. Stealing the SAML signing certificate (Path 1)
    2. Adding to or modifying existing federation trust (Path 2)
  3. Using attacker-created SAML tokens to access cloud resources and perform actions leading to the exfiltration of emails and persistence in the cloud

Diagram of the high-level Solorigate attack chain

Figure 1. High-level end-to-end Solorigate attack chain

This attack is an advanced and stealthy campaign with the ability to blend in, which could allow attackers to stay under the radar for long periods of time before being detected. The deeply integrated cross-domain security capabilities in Microsoft 365 Defender can empower organizations and their security operations (SOC) teams to uncover this attack, scope out the end-to-end breach from endpoint to the cloud, and take action to block and remediate it. This blog will offer step-by-step guidance to do this by outlining:

  • How indicators of attack show up across endpoints, identity, and the cloud
  • How Microsoft 365 Defender automatically combines alerts across these different domains into a comprehensive end-to-end story
  • How to leverage the powerful toolset available for deep investigation, hunting, and response to enable SOCs to battle the attackers and evict these attackers from both on-premises and cloud environments

Threat analytics: Understanding and responding to active attacks

As soon as this attack was discovered, Microsoft researchers published two threat analytics reports to help organizations determine if they are affected, assess the impact of the attack, and identify actions to contain it.

The reports are published in Microsoft 365 security center, available to all Microsoft Defender for Endpoint customers and Microsoft 365 Defender early adopters. In addition to detailed descriptions of the attack, TTPs, and indicators of compromise (IoCs), the reports provide real-time data aggregated from signals across Microsoft 365 Defender, indicating the all-up impact of the threat to the organization, as well as details about relevant incidents and alerts to initiate investigation on. These reports continue to be updated as additional information becomes available.

Given the significance of this threat, we are making similar relevant Microsoft threat intelligence data, including the updated list of IOCs, available to everyone publicly.  A comprehensive list of guidance and insights is available at https://aka.ms/solorigate.

Screenshot of threat analytics report on Soloriage in Microsoft Defender Security Center

Figure 2. Threat analytics report on Solorigate attack

We recommend Microsoft 365 Defender customers to start their investigations here. After gaining deep understanding of the threat and getting the latest research findings, you can take the following recommended steps:

Find devices with the compromised SolarWinds Orion application

The threat analytics report uses insights from threat and vulnerability management to identify devices that have the compromised SolarWinds Orion Platform binaries or are exposed to the attack due to misconfiguration.

From the Vulnerability patching status chart in threat analytics, you can view the mitigation details to see a list of devices with the vulnerability ID TVM-2020-0002, which was added specifically to help with Solorigate investigations:

Threat and vulnerability management insights on impact of Solorigate

Figure 3. Threat and vulnerability management data shows data on exposed devices

Threat and vulnerability management provides more info about the vulnerability ID TVM-2020-0002, as well as all relevant applications, via the Software inventory view. There are also multiple security recommendations to address this specific threat, including instructions to update the software versions installed on exposed devices.

Screenshot of security recommendations for Solorigate in Microsoft Defender Security Center

Figure 4. Security recommendations from threat and vulnerability management

Investigate related alerts and incidents

From the threat analytics report, you can quickly locate devices with alerts related to the attack. The Devices with alerts chart identifies devices with malicious components or activities known to be directly related to Solorigate. Click through to get the list of alerts and investigate.

Some Solorigate activities may not be directly tied to this specific threat but will trigger alerts due to generally suspicious or malicious behaviors. All alerts in Microsoft 365 Defender provided by different Microsoft 365 products are correlated into incidents. Incidents help you see the relationship between detected activities, better understand the end-to-end picture of the attack, and investigate, contain, and remediate the threat in a consolidated manner.

Review incidents in the Incidents queue and look for those with alerts relevant to this attacker’s TTPs, as described in the threat analytics report (also listed at the end of this blog).

Screenshot of Microsoft Defender Security Center incidents view for Solorigate

Figure 5. Consolidated Incident view for Solorigate

Some alerts are specially tagged with Microsoft Threat Experts to indicate malicious activities that Microsoft researchers found in customer environments during hunting. As part of the Microsoft Threat Experts service, researchers investigated this attack as it unfolded, hunting for associated attacker behaviors, and sent targeted attack notifications. If you see an alert tagged with Microsoft Threat Experts, we strongly recommend that you give it immediate attention.

Screenshot of Microsoft Defender Security Center showing Microsoft Threat Experts detections

Figure 6. Microsoft Threat Experts targeted attack notification

Additionally, Microsoft Threat Experts customers with Experts on demand subscriptions can reach out directly to our on-demand hunters for additional help in understanding the Solorigate threat and the scope of its impact in their environments.

Hunt for related attacker activity

The threat analytics report also provides advanced hunting queries that can help analysts locate additional related or similar activities across endpoint, identity, and cloud. Advanced hunting uses a rich set of data sources, but in response to Solorigate, Microsoft has enabled streaming of Azure Active Directory (Azure AD) audit logs into advanced hunting, available for all customers in public preview. These logs provide traceability for all changes done by various features within Azure AD. Examples of audit logs include changes made to any resources within Azure AD, such as adding or removing users, apps, groups, roles, and policies.  Customers who do not have Microsoft Defender for Endpoint or are not early adopters for Microsoft 365 Defender can see our recommended advanced hunting queries.

Currently, this data is available to customers who have Microsoft Cloud App Security with the Office365 connector. Our intent is to expand availability to more Microsoft 365 Defender customers. The new log data is available in the CloudAppEvents table:

CloudAppEvents
| where Application == “Office 365”

The log data contains activity logs useful for investigating and finding Azure AD-related activities. This data further enriches the CloudAppEvents table, which also has Exchange Online and Microsoft Teams activities.

As part of making this new data available, we also published a handful of relevant advanced hunting queries, identified by the suffix [Solorigate], to the GitHub repo.

Here’s an example query that helps you see when credentials are added to an Azure AD application after ‘Admin Consent’ permissions were granted:

CloudAppEvents
| where Application == “Office 365”
| where ActionType == “Consent to application.”
| where RawEventData.ModifiedProperties[0].Name == “ConsentContext.IsAdminConsent” and RawEventData.ModifiedProperties[0].NewValue == “True”
| extend spnID = tostring(RawEventData.Target[3].ID)
| parse RawEventData.ModifiedProperties[4].NewValue with * “=> [[” dummpy “Scope: ” After “]]” *
| extend PermissionsGranted = split(After, “]”,0)
| project ConsentTime = Timestamp , AccountDisplayName , spnID , PermissionsGranted
| join (
CloudAppEvents
| where Application == “Office 365”
| where ActionType == “Add service principal credentials.” or ActionType == “Update application – Certificates and secrets management “
| extend spnID = tostring(RawEventData.Target[3].ID)
| project AddSecretTime = Timestamp, AccountDisplayName , spnID
) on spnID
| where ConsentTime < AddSecretTime and AccountDisplayName <> AccountDisplayName1

Microsoft 356 Defender advanced hunting can also assist in many of the recommended incident investigation tasks outlined in the blog, Advice for incident responders on recovery from systemic identity compromises.

In the remaining sections, we will discuss select examples of alerts raised by Microsoft 365 solutions that monitor and detect Solorigate activities across the attack chain on endpoint, identity, and the cloud. These are alerts you may encounter when investigating incidents in Microsoft 365 security center if your organization is affected by this threat. We will also indicate activities which are now blocked by Microsoft 365 Defender. Lastly, each section contains examples of hunting queries you will find useful for hunting for various attacker activities in your environment.

Detecting and blocking malware and malicious behavior on endpoints

Diagram showing attack chain on endpoints involving the Solorigate malware

Figure 7. Solorigate attack chain: Initial access and command-and-control

Discovering and blocking backdoor activity

When the compromised SolarWinds binary SolarWinds.Orion.Core.BusinessLayer.dll gets loaded on a device through normal update channels, the backdoor goes through an extensive list of checks to ensure it’s running in an actual enterprise network and not on an analyst’s machine. It then contacts a command-and-control (C2) server using a subdomain that is generated partly with information gathered from the affected device, which means a unique subdomain is generated for each affected domain. The backdoor allows the attackers to remotely run commands on the device and move to the next stages of the attack. For more information, read our in-depth analysis of the Solorigate malware.

Microsoft Defender for Endpoint delivers comprehensive protection against this threat (see full list of detection and protection alerts at the end of this blog). Microsoft Defender Antivirus, the default antimalware solution on Windows 10, detects and blocks the malicious DLL and its behaviors. It quarantines the malware, even if the process is running.

Screenshot of Microsoft Defender Security Center showing alert for blocking of Solorigate malware

Figure 8. Microsoft Defender for Endpoint blocks malicious binaries

If the malicious code is successfully deployed, the backdoor lies dormant for up to two weeks. It then attempts to contact numerous C2 domains, with the primary domain being *.avsvmcloud[.]com. The backdoor uses a domain generation algorithm to evade detection. Microsoft 365 Defender detects and blocks this behavior.

Screenshot of Microsoft Defender Security Center showing alert for malicious network connection

Figure 9. Microsoft Defender for Endpoint prevented malicious C2 callback

Discovering potentially tampered devices

To evade security software and analyst tools, the Solorigate malware enumerates the target system looking for certain running processes, loaded drivers, and registry keys, with the goal of disabling them.

The Microsoft Defender for Endpoint sensor is one of the processes the malware attempts to disable. Microsoft Defender for Endpoint has built-in protections against many techniques attackers use to disable endpoint sensors ranging from hardened OS protection, anti-tampering policies, and detections for a variety of tampering attempts, including “Attempt to stop Microsoft Defender for Endpoint sensor”, “Tampering with Microsoft Defender for Endpoint sensor settings”, or “Possible sensor tampering in memory”.

Successfully disabling Microsoft Defender for Endpoint can prevent the system from reporting observed activities. However, the multitude of signals reported into Microsoft 365 Defender provides a unique opportunity to hunt for systems where the tampering technique used might have been successful. The following advanced hunting query can be used to locate devices that should be reporting but aren’t:

// Times to be modified as appropriate
let timeAgo=1d;
let silenceTime=8h;
// Get all silent devices and IPs from network events
let allNetwork=materialize(DeviceNetworkEvents
| where Timestamp > ago(timeAgo)
and isnotempty(LocalIP)
and isnotempty(RemoteIP)
and ActionType in (“ConnectionSuccess”, “InboundConnectionAccepted”)
and LocalIP !in (“127.0.0.1”, “::1”)
| project DeviceId, Timestamp, LocalIP, RemoteIP, ReportId);
let nonSilentDevices=allNetwork
| where Timestamp > ago(silenceTime)
| union (DeviceProcessEvents | where Timestamp > ago(silenceTime))
| summarize by DeviceId;
let nonSilentIPs=allNetwork
| where Timestamp > ago(silenceTime)
| summarize by LocalIP;
let silentDevices=allNetwork
| where DeviceId !in (nonSilentDevices)
and LocalIP !in (nonSilentIPs)
| project DeviceId, LocalIP, Timestamp, ReportId;
// Get all remote IPs that were recently active
let addressesDuringSilence=allNetwork
| where Timestamp > ago(silenceTime)
| summarize by RemoteIP;
// Potentially disconnected devices were connected but are silent
silentDevices
| where LocalIP in (addressesDuringSilence)
| summarize ReportId=arg_max(Timestamp, ReportId), Timestamp=max(Timestamp), LocalIP=arg_max(Timestamp, LocalIP) by DeviceId
| project DeviceId, ReportId=ReportId1, Timestamp, LocalIP=LocalIP1

Microsoft is continuously developing additional measures to both block and alert on these types of tampering activities.

Detecting hands-on-keyboard activity within an on-premises environment

Diagram showing Solorigate hands-on-keyboard attack on premises

Figure 10. Solorigate attack chain: Hands-on-keyboard attack on premises

After establishing a backdoor connection on an affected device, the attacker’s next goal is to achieve off-premises access to the organization’s cloud services. To do this, they must find a way to gain permissions to those services. One technique we have seen the attackers use is to go after the organization’s Active Directory Federation Services (AD FS) server to obtain the proverbial “keys” to the identity kingdom. AD FS enables federated identity and access management by securely sharing digital identity and entitlement rights across security and enterprise boundaries; effectively, it is the “LSASS for the cloud.” Among other things, AD FS stores the Security Assertion Markup Language (SAML) token signing certificate, which is used to create authorization tokens for users or services in the organization so they can access cloud applications and resources after authentication.

To attack the AD FS infrastructure, the attackers must first obtain appropriate domain permissions through on-premises intelligence gathering, lateral movement, and credential theft. Building from the backdoor described above, the attackers leverage fileless techniques for privilege escalation, persistence, and lateral movement, including evading analysis by using system binaries and exploration tools that masquerade as other benign binaries. The attackers also carefully chose organization-specific command-and-control (C2) domains and use custom organization-specific tool naming and locations.

Microsoft Defender for Endpoint detects a wide array of these attack techniques, allowing SOC teams to track the attacker’s actions in the environment and take actions to contain the attack. The following section covers detections for the techniques used by the attackers to compromise the AD FS infrastructure.

Identifying attacker reconnaissance

Attackers collect data from Active Directory using a renamed version of the utility ADFind, running queries against Domain Controllers as part of the reconnaissance stage of the attack. Microsoft Defender for Endpoint detects this behavior and allows the SOC analyst to track compromised devices at this stage to gain visibility into the information the attacker is looking for.

Screenshot of Microsoft Defender Security Center alert for detection of exploration tools

Figure 11. Microsoft Defender for Endpoint detects usage of masquerading exploration tools

Screenshot of Microsoft Defender Security Center alert for detection of LDAP queries

Figure 12. Microsoft Defender for Endpoint detects usage LDAP query for reconnaissance.

Stopping lateral movement and credential theft

To gain access to a highly privileged account needed for later steps in the kill chain, the attackers move laterally between devices and dump credentials until an account with the needed privileges is compromised, all while remaining as stealthy as possible.

A variety of credential theft methods, such as dumping LSASS memory, are detected and blocked by Microsoft Defender for Endpoint. The example below shows the detection of lateral movement using Windows Management Instrumentation (WMI) to run the attacker’s payload using the Rundll32.exe process.

Screenshot of Microsoft Defender Security Center alert for detection of remote WMI execution

Figure 13. Microsoft Defender for Endpoint alert for suspicious remote WMI execution highlighting the attacker’s device and payload

Microsoft Defender for Identity also detects and raises alerts on a variety of credential theft techniques. In addition to watching for alerts, security analysts can hunt across identity data in Microsoft 365 Defender for signs of identity compromise. Here are a couple of example Microsoft Defender for Identity queries looking for such patterns:

Enumeration of high-value DC assets followed by logon attempts to validate stolen credentials in time proximity

let MaxTime = 1d;
let MinNumberLogon = 5;
//devices attempting enumeration of high-value DC
IdentityQueryEvents
| where Timestamp > ago(30d)
| where Application == “Active Directory”
| where QueryTarget in (“Read-only Domain Controllers”)
//high-value RODC assets
| project Timestamp, Protocol, Query, DeviceName, AccountUpn
| join kind = innerunique (
//devices trying to logon {MaxTime} after enumeration
IdentityLogonEvents
| where Timestamp > ago(30d)
| where ActionType == “LogonSuccess”
| project LogonTime = Timestamp, DeviceName, DestinationDeviceName) on DeviceName
| where LogonTime between (Timestamp .. (Timestamp + MaxTime))
| summarize n=dcount(DestinationDeviceName), TargetedDC = makeset(DestinationDeviceName) by Timestamp, Protocol, DeviceName
| where n >= MinNumberLogon

High-volume of LDAP queries in short time filtering for non-DC devices

let Threshold = 12;
let BinTime = 1m;
//approximate list of DC
let listDC=IdentityDirectoryEvents
| where Application == “Active Directory”
| where ActionType == “Directory Services replication”
| summarize by DestinationDeviceName;
IdentityQueryEvents
| where Timestamp > ago(30d)
//filter out LDAP traffic across DC
| where DeviceName !in (listDC)
| where ActionType == “LDAP query”
| parse Query with * “Search Scope: ” SearchScope “, Base Object:” BaseObject “, Search Filter: ” SearchFilter
| summarize NumberOfDistinctLdapQueries = dcount(SearchFilter) by DeviceName, bin(Timestamp, BinTime)
| where NumberOfDistinctLdapQueries > Threshold

At this point, SOC teams can take containment measures within the Microsoft 365 security center, for example, using indicators to isolate the devices involved and block the remotely executed payload across the environment, as well as mark suspect users as compromised.

Detecting and remediating persistence

Microsoft Defender for Endpoint also detects the advanced defense evasion and masquerading techniques used by the attackers to make their actions as close to normal as possible, such as binding a WMI event filter with a logical consumer to remain persistent. Follow the recommended actions in the alert to remove persistence and prevent the attacker’s payload from loading after reboot.

Screenshot of Microsoft Defender Security Center alert for detection of WMI event filter bound to suspicious consumer

Figure 14. Microsoft Defender for Endpoint alert for WMI event filter bound to a suspicious consumer showing the persistence and the scheduled command line

Catching AD FS compromise and the attacker’s ability to impersonate users in the cloud

The next step in the attack focuses on the AD FS infrastructure and can unfold in two separate paths that lead to the same outcome—the ability to create valid SAML tokens allowing impersonation of users in the cloud:

  • Path 1 – Stealing the SAML signing certificate: After gaining administrative privileges in the organization’s on-premises network, and with access to the AD FS server itself, the attackers access and extract the SAML signing certificate. With this signing certificate, the attackers create valid SAML tokens to access various desired cloud resources as the identity of their choosing.
  • Path 2 – Adding to or modifying existing federation trust: After gaining administrative Azure Active Directory (Azure AD) privileges using compromised credentials, the attackers add their own certificate as a trusted entity in the domain either by adding a new federation trust to an existing tenant or modifying the properties of an existing federation trust. As a result, any SAML token they create and sign will be valid for the identity of their choosing.

In the first path, obtaining the SAML signing certificate normally entails first querying the private encryption key that resides on the AD FS container and then using that key to decrypt the signing certificate. The certificate can then be used to create illicit but valid SAML tokens that allow the actor to impersonate users, enabling them to access enterprise cloud applications and services.

Microsoft Defender for Endpoint and Microsoft Defender for Identity detect the actions that attackers take to steal the encryption key needed to decrypt the SAML signing certificate. Both solutions leverage unique LDAP telemetry to raise high-severity alerts highlighting the attacker’s progress towards creating illicit SAML tokens.

Screenshot of Microsoft Defender Security Center alert for LDAP query and AD FS private key extraction 

Figure 15. Microsoft Defender for Endpoint detects a suspicious LDAP query being launched and an attempted AD FS private key extraction

Figure 16. Microsoft Defender for Identity detects private key extraction via malicious LDAP requests

For the second path, the attackers create their own SAML signing certificate outside of the organization’s environment. With Azure AD administrative permissions, they then add the new certificate as a trusted object. The following advanced hunting query over Azure AD audit logs shows when domain federation settings are changed, helping to discover where the attackers configured the domain to accept authorization tokens signed by their own signing certificate. As these are rare actions, we advise verifying that any instances identified are the result of legitimate administrative activity.

ADFSDomainTrustMods

let auditLookback = 1d; CloudAppEvents
| where Timestamp > ago(auditLookback)
| where ActionType =~ “Set federation settings on domain.”
| extend targetDetails = parse_json(ActivityObjects[1])
| extend targetDisplayName = targetDetails.Name
| extend resultStatus = extractjson(“$.ResultStatus”, tostring(RawEventData), typeof(string))
| project Timestamp, ActionType, InitiatingUserOrApp=AccountDisplayName, targetDisplayName, resultStatus, InitiatingIPAddress=IPAddress, UserAgent

If the SAML signing certificate is confirmed to be compromised or the attacker has added a new one, follow the best practices for invalidating through certificate rotation to prevent further use and creation of SAML tokens by the attacker. Additionally, affected AD FS servers may need to be isolated and remediated to ensure no remaining attacker control or persistence.

If the attackers accomplish either path, they gain the ability to create illicit SAML tokens for the identities of their choosing and bypass multifactor authentication (MFA), since the service or application accepting the token assumes MFA is a necessary previous step in creating a properly signed token. To prevent attackers from progressing to the next stage, which is to access cloud resources, the attack should be discovered and remediated at this stage.

Detecting the hands-on-keyboard activity in the cloud environment

Diagram of hands-on-keyboard attacks in the cloud

Figure 17. Solorigate attack chain: Hands-on-keyboard attack in the cloud

With the ability to create illicit SAML tokens, the attackers can access sensitive data without having to originate from a compromised device or be confined to on-premises persistence. By abusing API access via existing OAuth applications or service principals, they can attempt to blend into the normal pattern of activity, most notably apps or service principals with existing Mail.Read or Mail.ReadWrite permissions to read email content via Microsoft Graph from Exchange Online. If the application does not already have read permissions for emails, then the app may be modified to grant those permissions.

Identifying unusual addition of credentials to an OAuth app

Microsoft Cloud App Security (MCAS) has added new automatic detection of unusual credential additions to an OAuth application to alert SOCs about apps that have been compromised to extract data from the organization. This detection logic is built on an anomaly detection engine that learns from each user in the environment, filtering out normal usage patterns to ensure alerts highlight real attacks and not false positives. If you see this alert in your environment and confirm malicious activity, you should take immediate action to suspend the user, mark the user as compromised, reset the user’s password, and remove the credential additions. You may consider disabling the application during investigation and remediation.

Figure 18. Microsoft Defender Cloud App Security alert for unusual addition of credentials to an OAuth app

SOCs can use the following Microsoft 365 Defender advanced hunting query over Azure AD audit logs to examine when new credentials have been added to a service principle or application. In general, credential changes may be rare depending on the type and use of the service principal or application. SOCs should verify unusual changes with their respective owners to ensure they are the result of legitimate administrative actions.

NewAppOrServicePrincipalCredential

let auditLookback = 1d; CloudAppEvents
| where Timestamp > ago(auditLookback)
| where ActionType in (“Add service principal.”, “Add service principal credentials.”, “Update application – Certificates and secrets management “)
| extend RawEventData = parse_json(RawEventData)
| where RawEventData.ResultStatus =~ “success”
| where AccountDisplayName has “@”
| extend targetDetails = parse_json(ActivityObjects[1])
| extend targetId = targetDetails.Id
| extend targetType = targetDetails.Type
| extend targetDisplayName = targetDetails.Name
| extend keyEvents = RawEventData.ModifiedProperties
| where keyEvents has “KeyIdentifier=” and keyEvents has “KeyUsage=Verify”
| mvexpand keyEvents
| where keyEvents.Name =~ “KeyDescription”
| parse keyEvents.NewValue with * “KeyIdentifier=” keyIdentifier:string “,KeyType=” keyType:string “,KeyUsage=” keyUsage:string “,DisplayName=” keyDisplayName:string “]” *
| parse keyEvents.OldValue with * “KeyIdentifier=” keyIdentifierOld:string “,KeyType” *
| where keyEvents.OldValue == “[]” or keyIdentifier != keyIdentifierOld
| where keyUsage == “Verify”
| project-away keyEvents
| project Timestamp, ActionType, InitiatingUserOrApp=AccountDisplayName, InitiatingIPAddress=IPAddress, UserAgent, targetDisplayName, targetId, targetType, keyDisplayName, keyType, keyUsage, keyIdentifier

Discovering malicious access to mail items

OAuth applications or service principals with Mail.Read or Mail.ReadWrite permissions can read email content from Exchange Online via the Microsoft Graph. To help increase visibility on these behaviors, the MailItemsAccessed action is now available via the new Exchange mailbox advanced audit functionality. See if this feature is enabled by default for you. Important note for customers: If you have customized the list of audit events you are collecting, you may need to manually enable this telemetry.

If more than 1,000 MailItemsAccessed audit records are generated in less than 24 hours, Exchange Online stops generating auditing records for MailItemsAccessed activity for 24 hours and then resumes logging after this period. This throttling behavior is a good starting point for SOCs to discover potentially compromised mailboxes.

MailItemsAccessedThrottling

let starttime = 2d;
let endtime = 1d;
CloudAppEvents
| where Timestamp between (startofday(ago(starttime))..startofday(ago(endtime)))
| where ActionType == “MailItemsAccessed”
| where isnotempty(RawEventData[‘ClientAppId’]) and RawEventData[‘OperationProperties’][1] has “True”
| project Timestamp, RawEventData[‘OrganizationId’],AccountObjectId,UserAgent

In addition to looking for throttled telemetry, you can also hunt for OAuth applications reading mail via the Microsoft Graph API whose behavior has changed prior to a baseline period.

OAuthGraphAPIAnomalies

//Look for OAuth App reading mail via GraphAPI — that did not read mail via graph API in prior week
let appMailReadActivity = (timeframeStart:datetime, timeframeEnd:datetime) {
CloudAppEvents
| where Timestamp between (timeframeStart .. timeframeEnd)
| where ActionType == “MailItemsAccessed”
| where RawEventData has “00000003-0000-0000-c000-000000000000” // performance check
| extend rawData = parse_json(RawEventData)
| extend AppId = tostring(parse_json(rawData.AppId))
| extend OAuthAppId = tostring(parse_json(rawData.ClientAppId)) // extract OAuthAppId
| summarize by OAuthAppId
};
appMailReadActivity(ago(1d),now()) // detection period
| join kind = leftanti appMailReadActivity(ago(7d),ago(2d)) // baseline period
on OAuthAppId

Microsoft 365 Defender’s cross-domain XDR correlation enables stronger response to critical security incidents

Like the rest of the security industry, Microsoft continues to track the Solorigate attack, an active threat that continues to unfold as well as evolve. As part of empowering our customers and the larger security community to respond to this attack through sharing intelligence and providing advice, this blog serves to guide Microsoft 365 customers to take full advantage of the comprehensive visibility and the rich investigation tools available in Microsoft 365 Defender. This blog shows that many of the existing capabilities in Microsoft 365 Defender help address this attack, but the unique scenarios created by the threat resulted in some Solorigate-specific detections and other innovative protections, including ones that are made possible by deeply integrated cross-domain threat defense.

For additional information and further guidance, refer to these Microsoft resources:

Microsoft will continue to provide public information about the patterns and techniques of this attack and related intelligence for customers to defend themselves, in addition to enhancing the protection capabilities of Microsoft security solutions.

Appendix: Additional details for detection and hunting

Detection details

Attack stage Microsoft 365 Defender detection or alert
Initial access Microsoft Defender for Endpoint:

  • ‘Solorigate’ high-severity malware was detected/blocked/prevented (Trojan:MSIL/Solorigate.BR!dha)
  • SolarWinds Malicious binaries associated with a supply chain attack
Execution and persistence Microsoft Defender for Endpoint:
Command and Control Microsoft Defender for Endpoint:
Defense evasion Microsoft Defender for Endpoint:

  • Suspicious audit policy tampering
Reconnaissance Microsoft Defender for Endpoint:

  • Masquerading Active Directory exploration tool
  • Suspicious sequence of exploration activities
  • Execution of suspicious known LDAP query fragments
Credential access Microsoft Defender for Endpoint:

  • Suspicious access to LSASS (credential access)
  • AD FS private key extraction attempt
  • Possible attempt to access ADFS key material
  • Suspicious ADFS adapter process created

Microsoft Defender for Identity:

  • Unusual addition of permissions to an OAuth app
  • Active Directory attributes Reconnaissance using LDAP

Microsoft Cloud App Security:

  • Unusual addition of credentials to an OAuth app
Lateral movement Microsoft Defender for Endpoint

  • Suspicious file creation initiated remotely (lateral movement)
  • Suspicious Remote WMI Execution (lateral movement)
Exfiltration Microsoft Defender for Endpoint

  • Suspicious mailbox export or access modification
  • Suspicious archive creation

Advanced hunting queries

Posted on Leave a comment

‘Wonder Woman 1984’ teams up with Xbox and Gamers Outreach to surprise children’s hospitals

This holiday season, the action-adventure film “Wonder Woman 1984” is teaming up with Xbox and Gamers Outreach to create 10 unique Gamers Outreach (GO) Karts, featuring the new Xbox Series S along with two custom Xbox Wireless Controllers inspired by the movie. Each of these GO Karts will be placed in children’s hospitals across the country starting on December 23, just in time to experience the magic of the holidays.

Children at these hospitals will be able to power their dreams as they continue the healing process, while Xbox and Gamers Outreach help bring a sense of normalcy to patients and families alike. As an extra gift of wonder, the GO Karts will include a special message from Wonder Woman herself, Gal Gadot, along with an HBO Max subscription to watch her new movie “Wonder Woman 1984,” streaming exclusively on HBO Max starting on December 25 for a limited time and available in theaters worldwide this holiday season.

The following hospitals will be receiving these specialized GO Karts:

  • Phoenix Children’s Hospital
  • Hassenfeld Children’s Hospital at NYU Langone
  • Children’s Minnesota
  • Johns Hopkins Children’s Center
  • Monroe Carell Jr. Children’s Hospital at Vanderbilt
  • Children’s Medical Center Dallas
  • Children’s Hospital New Orleans
  • SSM Health Cardinal Glennon Children’s Hospital
  • Montana Children’s Medical Center
  • Children’s National Hospital

Xbox and Gamers Outreach are once again excited to bring an unforgettable experience to children at these hospitals, giving them access to interactive entertainment and the chance to socialize via video games through an amazing collaboration with “Wonder Woman 1984,” bringing joy through the power of play with Xbox this holiday season.

Learn more about Gamers Outreach and their mission to build a world where play is accessible in hospitals by visiting www.GamersOutreach.org.

Posted on Leave a comment

2020 in review: 6 most-read posts from Microsoft on the Issues

As Covid-19 affected our personal and working lives, 2020 was a year of unimaginable change. Microsoft on the Issues covered topics including cybersecurity, digital skills accessibility and more, and the pandemic influenced many of the stories we brought you.

As we say goodbye to 2020, here’s a look at some of this year’s most read stories, from the Puget Sound region and beyond.

Data, supplies, community: How Microsoft is supporting efforts to combat Covid-19

Family, friends and co-workers around the world are facing the effects of the Covid-19 pandemic. Managing response efforts requires the cooperation of every sector of society. Back in March, we offered this resource to communities, non-profits and government officials.

Everyone should have access to digital skills. New grants aim to help

Microsoft’s skills initiative hopes to help 25 million people around the world secure digital skills. In June, Microsoft made a public commitment to be more inclusive as an employer and to extend Microsoft’s support and outreach programs in Black and African American communities. As part of this, Microsoft’s community skills program will provide financial grants and tech enablement to community-based non-profits reaching 5 million unemployed workers who need it most.

This is a look at i.c.stars, a rigorous, tech-focused program that provides young adults from low-income communities with the tools to develop the technical and leadership skills needed for a career in technology, a field that continues to lack diversity and be in high demand.

What is ElectionGuard?

Every election year, millions of Americans are eligible to cast their ballots to elect officials ranging from members of school boards to the President of the United States. Those millions of voters need to be confident that the democratic process is carried out without interference.

However, in recent years, technology designed to help elections run smoothly has been targeted by those seeking to influence, subvert or sabotage democracy. Microsoft has been working with governments, NGOs, academics and industry on the Defending Democracy Program. One of the components is ElectionGuard, explored in this article.

An inside look at the global battle with botnets

In March, a small team at Microsoft dismantled Necurs, one of the world’s largest botnets. It was a project that was eight years in the making, and involved coordinated legal and technical action from 35 countries. Botnets are highly sophisticated, acting as a unified threat and often run by well-resourced operators. Tracking them down and preventing them from carrying out further infections and attacks is a complex task that takes coordination across geographies and organizations. This article explored the battle with botnets around the world.

Understanding accessibility through ABCs

At Microsoft, we focus on the maxim of “nothing about us, without us” in order to create technology for people with and without disabilities. Creating and developing technologies for everybody to use involves embracing diversity and an inclusive culture in Microsoft’s own workforce.

The main obstacle to inclusion and diversity is the lack of awareness. As a starting point to educate and share, we shared our ABCs of Accessibility, from A to Z.

How AI is helping map the world’s most vulnerable places

There are places in the world that have not been mapped in detail. In the event of a natural disaster that can be a problem, as rescue teams try to understand where their help might be needed. The Humanitarian OpenStreetMap Team, or HOT, is working with Microsoft’s AI for Humanitarian Action program and Bing to combine satellite mapping, machine learning and an army of volunteers to create detailed and potentially life-saving maps. This story looks at the work HOT is doing, particularly across Africa, and explains how these maps are part of the effort to contain Ebola.

Posted on Leave a comment

Get into the holiday spirit on Skype

24/12/2020 | Skype Blogs | Holidays on Skype

The holidays are upon us! Skype has traditionally played a key role keeping people connected during the holiday season, and this year that’s more important than ever. To that end, Skype has gotten all dressed up with your favorite holiday emojis, expressions and new background designs to help make it a magical, memorable season. We like to call it the “Holidification” of Skype!

Express yourself in the spirit of the season with friends and family

There’s so much more to a conversation than speaking. A smile, a wink, a hand signal, the nod of the head, or even a quiet little chuckle: it deepens, enriches, and engages. Did the story your Uncle John just told make you sentimental? Pop a holiday tree emoji in the chat window. Talking with your cousin in London about whether reindeers really know how to fly? Give her Rudolph the Red-nosed Reindeer emoji with a blinking red nose! Get a sweet message from your Mom in the chat window? Respond to her comment with a holiday-themed reaction. Skype puts seasonal-themed emojis at your fingertips as you type!

“It’s all about creating more authentic connections,” says Sam Cundall, Animator and Principal Designer for Skype, Seattle, USA. “People should be able say something like, ‘wow, that sounds exactly like my friend Sam, he’s expressing himself the same way he would if he were in front of me.’ That’s the legacy of Skype’s quirkiness and humor: our emojis and expressions help make it as authentic as possible.”

Feel like you’re in a favorite holiday spot with Background Replace

Try one of our colorful holiday-themed backgrounds to set the mood. Or upload a moonscape for an out-of-this-world holiday. With Background Replace, your imagination rules. And you know how you usually have to deep-clean your place before a social get together? Not this year. One nice thing about celebrating remotely is you can use Background Replace to hide that messy living room! 

Did you know, Skype’s new ‘Together Mode’ feature brings even more fun to the festivities and makes you feel that you are in the same room when on a video chat with your friends and family; this way you can feel closer together even when apart.

“These are the latest of a multitude of beautiful rich backgrounds and themes we created this year in partnership with myriad talented artists and designers,” says Nando Costa, Microsoft Partner Director of Design, XC Storytelling. “As customers from around the globe depend on Skype for their communication needs in life, we are committed to bringing delightful and expressive moments to their everyday interactions.”

Spend as much time as you want together, now and throughout the year

Holiday celebrations tend to be filled with fun and festivities that can go on for hours, even days. That makes it kind of hard to fit everything into 40 minutes. With Skype, you can get together – free – with up to 100 people for up to 24 hours a day every day of the year. Your friends don’t need to have a Skype account either: With the Meet Now feature, it’s even easier to create video calls with just one click. No passwords. No sign-ups. Not even a download is needed! So go wild: enjoy as much time as you want sharing stories, showing off your favorite “ugly” holiday sweaters, playing games, and more. While you’re online, make some plans not just for the holidays but for birthdays, anniversaries, and other big events in the coming year. Because the time you spend together should be more than just for the holidays!

So, make this a season to remember, not because it’s the one where we all had to stay home – but the one where we still came together in the spirit of the holidays despite it all! We wish you a season filled with family, friends, and much cheer.

Happy Holidays!

We asked our teammates here at Skype about what the holidays means to them and here’s what some of them told us:

“Holidays are my favorite time of the year, especially when it comes to making memories! I love being able to connect with friends and family, whether close or far away. It’s also the time of year where I feel the most thankful the people who make life wonderful.”

–Luis Carrasco, Skype Global Product Director, San Cristobal, Venezuela

“Holidays are always a magical time for me. It’s a chance to make wonderful memories with friends and loved ones, even from a distance. Of course, I also find time to make ALL my favorite foods and play video games. Like I said: it’s a magical time!”

–Jane Gordina, Skype Software Engineer, Prague, Czech Republic

“For me, the holidays are a wonderful time of year where we can slow down and be with those we care about. I think it’s also about enjoying lots of great food, sharing, and giving. But most of all, it’s about being together even when apart.”

–Katerina Karellas, Skype Global Product Marketing Director, London, UK

“Holidays have been my favorite time of the year since I was a kid. That magical feeling of hearing holiday music, watching the lights shimmer throughout the neighborhood, and being surrounded by family and friends, is something I’ll never forget. Now that I have a family of my own, I am even more grateful for the time we spend together. The best part, though, is the spirit of giving.”

Adam Czeisler, Skype Engineering Director, Seattle, USA

“Holidays are one of the few times in the year when I can slow down and enjoy some truly unhurried time with my friends and family, near and far. This year, it’ll have to be mostly online, but I’m still eager and thankful to reconnect and just… chat!”

–Rohit Wad, Corporate Vice President, Issaquah, USA

Posted on Leave a comment

Virtual Reality update for Microsoft Flight Simulator now available

Microsoft Flight Simulator was built from the ground up to achieve three key goals: realism, accuracy, and authenticity of flight. Today, we’re excited to share that Virtual Reality for Microsoft Flight Simulator is now available on your favorite VR headset for PC, offering simmers the deepest and most immersive virtual flight experience in the new simulator to date.

The flight sim community has been a very active and insightful partner in shaping how the team approached VR, and continues to be a critical partner in our continued development as we make further improvements and add new features to the simulation. Adding VR to Microsoft Flight Simulator was a direct result of community feedback, and we look forward to continued involvement in the future of the franchise with us.

Our goal was to make this update accessible to as many VR players as possible. To achieve this goal, we have worked to make this free update compatible across a wide range of supported devices, including most Windows Mixed Reality headsets (including the HP Reverb G2), Oculus, Valve, and HTC headsets. To access VR, make sure you have downloaded the latest update for Microsoft Flight Simulator.

Grab your VR headset and try this captivating experience today on Xbox Game Pass for PC, Windows 10, and Steam. Feel free to share your first impressions with us on the dedicated forums or check out our FAQ if you have questions. For the latest information on Microsoft Flight Simulator, stay tuned to @MSFSOfficial on Twitter.

Xbox LiveXbox Live

Microsoft Flight Simulator: Standard

Xbox Game Studios

This title does not support Korean, Vietnamese, Thai or Indonesian localization. Microsoft Flight Simulator is the next generation of one of the most beloved simulation franchises. From light planes to wide-body jets, fly highly detailed and stunning aircraft in an incredibly realistic world. Create your flight plan and fly anywhere on the planet. Enjoy flying day or night and face realistic, challenging weather conditions. MICROSOFT FLIGHT SIMULATOR IS A MUST PLAY*: • 10/10 IGN – “Microsoft Flight Simulator is legitimately incredible. It’s difficult to fully describe how amazing it feels to jump into a plane and have the freedom fly to and from literally any place in the entire world.”
• Essential EUROGAMER – “a once in-a-generation wow moment”
• 100/100 GAMING TREND
• 100/100 PLAYER 2
• 5/5 GUARDIAN – “This game captures the wonder of flight”
• 5/5 VG 24/7
• 10/10 PRESS-START
• 10/10 AUSGAMERS
• 5/5 VGC – “phenomenal looking, remarkably detailed simulator”
• 9/10 AREAJUGONES
• 9/10 PC INVASION
• 4.5/5 ATTACK OF THE FANBOY
• 9/10 GAMEBLOG
• 10/10 WCCFTECH – “a technical marvel that brings the whole world to life and the best example of cloud based gaming so far.”
• 18/20 JEUXACTU
• 9/10 EVEREYE
• 9.3/10 SPAZIOGAMES
• 4/5 DAILY STAR – “the definition of revolutionary”
• 4.5/5 TWINFINITE

Posted on Leave a comment

CVP Tom Burt: Cyber mercenaries don’t deserve immunity

A growing industry of companies called private-sector offensive actors – or PSOAs – is creating and selling cyberweapons that enable their customers to break into people’s computers, phones and internet-connected devices. Now, one of these 21st-century mercenaries, called the NSO Group, is attempting to cloak itself in the legal immunity afforded its government customers, which would shield it from accountability when its weapons inflict harm on innocent people and businesses. The firm also contributes to the urgent cybersecurity challenges discussed by our president Brad Smith last week. We believe the NSO Group’s business model is dangerous and that such immunity would enable it and other PSOAs to continue their dangerous business without legal rules, responsibilities or repercussions. That’s why today we filed an amicus brief – along with Cisco, GitHub, Google, LinkedIn, VMWare and the Internet Association – in a legal case brought by WhatsApp against the NSO Group.

The NSO Group sold governments a program called Pegasus, which could be installed on a device simply by calling the device via WhatsApp; the device’s owner did not even have to answer. According to WhatsApp, the NSO Group used Pegasus to access more than 1,400 mobile devices, including those belonging to journalists and human rights defenders. We believe companies like NSO Group selling tools like Pegasus are concerning for three reasons.

First, their presence increases the risk that the weapons they create fall into the wrong hands. Previously, sophisticated nation-state hacking capabilities resided in a small number of governments with well-funded agencies focused on developing these weapons. Even then, government-created espionage tools got into the hands of other governments who used them in attacks like WannaCry and NotPetya that spread like wildfire beyond the targeted victims and ultimately devastated lives and disrupted businesses around the world. Lowering the barrier for access to these weapons would guarantee that such catastrophes would be repeated.

Even if the tools are sold to governments who use them for narrowly targeted attacks, there are a variety of ways they can still fall into the wrong hands. For example, private actors like the NSO Group and their less sophisticated customers may lack the defenses some governments use to protect the weapons, making them more susceptible to cyber-theft. For example, an Italian company called Hacking Team – one of NSO’s competitors – was itself hacked in 2015. Additionally, targets of these weapons can observe, reverse-engineer and then use these tools for their own purposes.

Second, private-sector companies creating these weapons are not subject to the same constraints as governments. Many governments with offensive cyber capabilities are subject to international laws, diplomatic consequences and the need to protect their own citizens and economic interests from the indiscriminate use of these weapons. Additionally, some governments – like the United States – may share high-consequence vulnerabilities they discover with impacted technology providers so the providers can patch the vulnerability and protect their customers. Private actors like the NSO Group are only incented to keep these vulnerabilities to themselves so they can profit from them, and the exploits they create are constantly recycled by governments and cybercriminals once they get into the wild.

Third, companies like the NSO Group threaten human rights whether they seek to or not. An analysis of recent cyber-attacks was able to identify five countries using offensive cyber capabilities between 2012 and 2015: Russia, China, North Korea, France and Israel. Between 2016 and 2018, however, the cast of characters changed to include countries like the United Arab Emirates and Uzbekistan. And public reporting has identified clients of cyber-surveillance companies like the NSO Group to include Azerbaijan, Bahrain, Egypt, Ethiopia, Kazakhstan, Mexico, Morocco, Nigeria, Oman, Saudi Arabia and Sudan. Reporting also shows foreign governments are using those surveillance tools, bought from PSOAs, to spy on human rights defenders, journalists and others, including U.S. citizens. These tools allow the user to track someone’s whereabouts, listen in on their conversations, read their texts and emails, look at their photographs, steal their contacts list, download their data, review their internet search history and more. Just yesterday The Citizen Lab reported that between July and August of this year NSO’s Pegasus program was used to hack 36 phones belonging to journalists, producers, anchors and executives at Al Jazeera. Privacy is fundamental to the ability of journalists to report, of dissidents to speak their voices and of democracy to flourish and these tools threaten their rights and their lives.

The expansion of sovereign immunity that NSO seeks would further encourage the burgeoning cyber-surveillance industry to develop, sell and use tools to exploit vulnerabilities in violation of U.S. law. Private companies should remain subject to liability when they use their cyber-surveillance tools to break the law, or knowingly permit their use for such purposes, regardless of who their customers are or what they’re trying to achieve. We hope that standing together with our competitors today through this amicus brief will help protect our collective customers and global digital ecosystem from more indiscriminate attacks.

Tags: , ,

Posted on Leave a comment

Start the new year with 3 ways to better organize your life

Our homes have never worked harder for us than they are right now. A home is our office, school, gym, sanctuary, and safe retreat from the world. That means it’s more important than ever to have organization systems in place to keep key parts of your home humming along.

See how these organization tips can help you achieve some of your New Year’s resolutions.

Discover an easier way to organize and manage your finances

Managing personal finances can be an unwelcome task for some people, but having the right tools can help make it easier. Join the millions of people who use Microsoft Excel to track their budgets, help simplify the task of managing finances, and to help stay on track with longer-term financial goals.

If you’re not a Microsoft 365 subscriber, there are some free templates you can use if you just want a simple tracking template or want to track your family’s monthly expenses. Just add your income and spending information and let the spreadsheets do the rest of the math for you.

Save time, organize and protect your computer files

Get the peace of mind that comes from knowing your computer files and photos are backed up and accessible to you wherever you go and whenever you need them. With OneDrive, your files sync between your computer and the cloud, so if you make changes on your computer, those changes are reflected in the file in the cloud—and vice versa.

You can work directly with your synced files anytime and can access your files even when you’re offline. Whenever you go online next, any changes you made while offline will sync automatically.

Organize and collect your thoughts while online

We all do it: While researching something online, we lose track of the key information we found. This year, discover a fun and visual way to track your ideas on the web by using Collections in Microsoft Edge. Collections allow you to easily identify your saved webpages by displaying the name, a quick summary, and a picture so you can find what you’re looking for at a glance.

Create collections to help you accomplish your New Year’s resolutions. Plan to eat better? Create a collection of recipes to try. Want to work out more? Create a collection of your favorite workout videos so you can easily find the video you want to watch each day. Looking to learn something new this year? Create a collection with videos and how-to pages to get you started.

You can also easily add Pinterest inspiration to your existing collection or export your entire collection to a new board on Pinterest. Whatever to-do list you have for 2021, you can capture it in a visually delightful way using Collections in Microsoft Edge.

Whether you’re looking to track and understand your spending better, to help protect your important files are protected, or to keep track of your ideas on the web, Microsoft has tools to help you take control and take charge in the new year.